SparkTrust

Support Center

What are the system requirements for SparkTrust MacCleaner Pro?

In order for SparkTrust MacCleaner Pro to function correctly and to take advantage of all the features it offers, you will need to check that your system meets the necessary requirements and recommendations. 

Minimum System Requirements: 
  • OS X versions 10.7 to 10.11
  • 20MB Hard drive space

Did you find this article helpful?

Contact Us

stsupport@nubrandsoftware.com
http://assets3.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete