Yes, it is!  SparkTrust MacCleaner Pro is compatible with MAC OS X 10.7 to 10.11